full of … these

Opensuse 11.0: how to fix sound and mic on dell vostro 1510

Posted: October 3rd, 2008 | Author: | Filed under: howto, linux | Tags: , , , , | 2 Comments »

Chris asked me to give more detail about what I did to make the sound work on my laptop.

Here is what I did after a fresh install of opensuse 11:

– first thing I did it was to install the wireless drivers
– install all available patches
– by reading and searching for a solution on google i have found this page very useful:
http://en.opensuse.org/SDB:AudioTroubleshooting

– I installed suggested packages by hitting:
rpm -q alsa alsa-utils alsa-firmware and I have made a test using
speaker-test -Dplug:front -c2 -l5 -twav as they mentioned, but the sound was interrupted.
– I ran alsaconf, but the same results
– Than I have added extra options to the config file: options snd-hda-intel enable=1 index=0 model=dell
– I restarted alsa daemon: rcalsasound restart and I was able to hear a clear sound
– I went to “Volume Control” in “Edit”->”Preferences” and I have added all available devices not checked, 5-6 or so. I have played around with the controls and I have setup the Front Mic boost and recording controls to 50% of the scale and in Options tab I have setup first “Input source” to Mic, and the second “Input source” to Front Mic.
– I restarted again alsa, and I could record me using “Sound recorder” scratching near by the camera.

I know, it’s a mess, but it did work.
In skype i have used the following configuration to listen and to be able to speak:
– Sound In: HDA Intel (hw:Intel,0)
– Sound Out: HDA Intel (hw:Intel,0)
– Ringing: Default device


2 Comments on “Opensuse 11.0: how to fix sound and mic on dell vostro 1510”

  1. 1Swift Arrow said at 8:10 am on September 28th, 2009:

    Hi! THANKs so much for your post!!!

    I’m running Ubuntu 9.04 on a Dell Vostro 1510 and was having trouble getting the mic to work!

    Now, following your directions, it works!!! Thanks!!!
    For fellow Ubuntu people out there, here’s how it is fixed:
    add the config line
    options snd-hda-intel enable=1 index=0 model=dell
    to the end of our /etc/modprobe.d/alsa-base.conf file
    restart alsa by running sudo alsa reload
    Set your mixers as indicated above.

    I’m using Skype 2.1B, and no changes to the skype audio settings were required.

  2. 2Swift Arrow said at 9:05 am on September 28th, 2009:

    I’ve written a detailed step-by-step for Ubuntu users: http://s227842398.onlinehome.us/testament/ubuntu-904-dell-vostro-1510-mic-problems


Leave a Reply