full of … these

Trac 0.11 – Fix Clearsilver dependency

Posted: November 20th, 2009 | Author: | Filed under: howto, idiots, linux | Tags: , , , | No Comments »

If you get the following message:

You're using a plugin which requires the Clearsilver template engine
and Clearsilver is not installed. Either disable that plugin or install Clearsilver.

But, you have compiled and installed latest clearsilver from sources and copied neo_cgi.so to site-packages, and still not working, here is what to you have to do.

For this environment was tested: Linux opensuse 11.1 and centos 5.2, Trac 0.11 with python 2.4 or 2.6, TracDownloader and/or TracWikiToPdfPlugin installed.

Search for clearsilver-*.egg in site-packages and move to another directory.

My clearsilver package name was: clearsilver-0.10.1-py2.6-linux-i686.egg
Restart apache.

Enjoy and say thanks if this solved your problem.



Leave a Reply