full of … these

Fix slow keyboard on Dell Inspiron 1501

Posted: January 7th, 2009 | Author: | Filed under: fun, howto | Tags: , , , , , , , , | 84 Comments »

One of my colleague asked me to take a look at her laptop and check why the characters appear so slow sometimes.
At that moment I thought it’s a software issue. After several checks we reinstalled the XP but the problem persisted. So, we sent the notebook to the service.
After one month, we received it untouched with the following resolution: please reinstall the OS :).
Ok then…

So I started to investigate by killing unneeded processes.
I have started with ati2evxx.exe.
I was lucky, after two days of tests it seems that this was the problem.
The exe is started by a service named ati hotkey poller (I can’t remember exactly right now).
This process is installed together with the Ati driver (catalyst).
I have changed the service settings to not start at boot time (it cannot be stopped) and rebooted.

The problem was resolved.

On another dell inspiron 1501, but with newer drivers, in the control center the hot key service is disabled by default. In the version from the CD with the drivers, the hot key service is enabled by default.

Update 1: Show me your happy face! if this works for you, you saved at least 500 euro…
Leave a comment if this fixed your laptop.

Update 2:

Edwin suggested below that the cause of this lag is because your batter is too old and you should replace it.
To test it, remove the battery and start your Dell.

If the battery replacement fixed the problem please leave a comment.


Opensuse 11.0: how to fix sound and mic on dell vostro 1510

Posted: October 3rd, 2008 | Author: | Filed under: howto, linux | Tags: , , , , | 2 Comments »

Chris asked me to give more detail about what I did to make the sound work on my laptop.

Here is what I did after a fresh install of opensuse 11:

– first thing I did it was to install the wireless drivers
– install all available patches
– by reading and searching for a solution on google i have found this page very useful:
http://en.opensuse.org/SDB:AudioTroubleshooting

– I installed suggested packages by hitting:
rpm -q alsa alsa-utils alsa-firmware and I have made a test using
speaker-test -Dplug:front -c2 -l5 -twav as they mentioned, but the sound was interrupted.
– I ran alsaconf, but the same results
– Than I have added extra options to the config file: options snd-hda-intel enable=1 index=0 model=dell
– I restarted alsa daemon: rcalsasound restart and I was able to hear a clear sound
– I went to “Volume Control” in “Edit”->”Preferences” and I have added all available devices not checked, 5-6 or so. I have played around with the controls and I have setup the Front Mic boost and recording controls to 50% of the scale and in Options tab I have setup first “Input source” to Mic, and the second “Input source” to Front Mic.
– I restarted again alsa, and I could record me using “Sound recorder” scratching near by the camera.

I know, it’s a mess, but it did work.
In skype i have used the following configuration to listen and to be able to speak:
– Sound In: HDA Intel (hw:Intel,0)
– Sound Out: HDA Intel (hw:Intel,0)
– Ringing: Default device


more about opensuse 11.0 on dell vostro 1510

Posted: September 1st, 2008 | Author: | Filed under: howto, linux | Tags: , , | No Comments »

I just want you to know that, somethimes, my keyboard freezes at boot time. But, if you press Esc after the green screen appears everything works as usual.

Strange…


opensuse 11 on dell inspiron 1501 and dell vostro 1510

Posted: August 14th, 2008 | Author: | Filed under: fun, howto, linux | Tags: , , , , , , | 14 Comments »

I got a new laptop from work, first thing to do with? … of course, install linux….
because ubuntu disappointed me, hdd problem convinced me to try something else (any distro you may chose, i’m pretty sure you have to hack drivers).

From previous experience with dell 1501, i prefered opensuse 11.0.
On 1501, everything was smooth: ndiswrapper for wifi (fwcutter and restricted driver are unstable) ati driver from the opensuse’s page (check http://en.opensuse.org/Ati).
Graphic performaces? Not even like in windows, too bad.

Now let’s get back to vostro 1510.
After installing opensuse 11 with gnome, the keyboard and touch pad did not work.
No fix on google.
No problem let’s try kde (last kde I had used was on redhat 9, that’s on 2003-2004).
After several minutes and one reboot I could log in. Strange to work with kde but not with gnome.
Those guys from gentoo said it’s becuase ACPI. Anyway it works.
Now let’s fix network:
– the wired network 🙂

rmmod/modprobe r8169 driver to have the wired internet working

– the wireless network

ndiswrapper saves the day, I’ll not give details, I add the fact that I have used XP drivers from dell.com.

For the video card:

go to opensuse’s page download the ymp file and use it with yast. For compiz use simple-ccsm.

Conclusions:

– opensuse 11.0 works better on dell 1501 than ubuntu (i have tried with ubuntu 6.06, 7.10 and 8.04);
– i have no ideea why gnome did not work (the keyboard was not working) and kde succeded to be used on vostro 1501;
– ubuntu is not the only and last alternative to windows on your desktop or laptop, I still have ubuntu installed, but sometime is a pain to modify/hack it;
– the video card from vostro (Nvidia Geforce 8400M) performs as expected (2600fps when running glxgears), compiz works perfect;
– no hdd problems when running opensuse on these two laptops, no need to modify the power management of the harddisk to save it’s life.

I’ll write more about these linux distro in combination with the laptops I have around.